Payment Issues
Incident Report for Spektrix
Resolved
After monitoring the payment errors, we are now marking this incident as resolved as we can see that card payments are continuing to process successfully . If you have any questions, please don't hesitate to get in touch with us at support@spektrix.com or 020 7183 3586 (UK/ROI) and
(646) 569-9097 (NA).
Posted Jun 02, 2021 - 15:45 BST
Monitoring
We're currently monitoring a situation where some of you may have seen some errors when attempting to take card payments through Spektrix. We believe the issue has been resolved and payments should now go through as expected, but we're going to continue to monitor the situation.
Posted Jun 02, 2021 - 15:26 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).