Issues with scheduling integrated emails
Incident Report for Spektrix
Resolved
North American users should no longer be seeing an error when attempting to create a new integrated email within Spektrix.
Posted 2 months ago. Aug 08, 2019 - 21:09 BST
Investigating
We have identified an issue where North American Spektrix systems are displaying an error when attempting to create a new integrated email within Spektrix. We are looking into the problem and will post here when we have more information. If you need to send an email campaign, contact us in Support for assistance.
Posted 2 months ago. Aug 08, 2019 - 20:21 BST
This incident affected: Spektrix System (Spektrix System - US/CAN).