NA Support: Toll-free number not working
Incident Report for Spektrix
Resolved
Our US toll-free line is now active! We apologize for this inconvenience and thank you for your patience. North American clients can reach the support team at both 1 -800-961-5971 and (646) 569-9097 or by submitting a ticket through the support center.
Posted Aug 07, 2018 - 17:40 BST
Investigating
We are not currently able to receive support calls via our US toll-free line. In the meantime, support for North American clients can be reached via (646) 569-9097. We will post an update here once the toll-free number is active again.
Posted Aug 06, 2018 - 20:16 BST
This incident affected: Support Services (Phone Service - North America).