Unexpected System Slowness
Incident Report for Spektrix
Resolved
The earlier issue with system slowdown has been resolved - all systems are returned to normal function and speeds.
Posted Aug 17, 2018 - 22:25 BST
Monitoring
We are continuing to monitor system speeds as they return to normal.
Posted Aug 17, 2018 - 20:51 BST
Update
We are continuing to investigate this issue.
Posted Aug 17, 2018 - 20:46 BST
Investigating
We are currently investigating some unexpected system slowness. We are working to resolve this issue, and will keep this page updated with the current status of the system.
Posted Aug 17, 2018 - 20:42 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).