US/CA Limited Phone Support
Incident Report for Spektrix
Resolved
US/CA phone service has been fully restored and we are confident that the underlying issue is resolved.
Posted 4 months ago. Jul 02, 2019 - 22:46 BST
Monitoring
US/CA phone service has been restored and should be working normally. We are still monitoring services for the time being to make sure everything has been resolved. Thank you again for your patience!
Posted 4 months ago. Jul 02, 2019 - 21:39 BST
Investigating
We are currently experiencing outages with phone service in the NY Office. This issue is currently being investigated. We are still available to be reached via email and we will be actively monitoring all voice messages. Thank you for your patience.
Posted 4 months ago. Jul 02, 2019 - 19:21 BST
This incident affected: Support Services (Phone Service - North America).