Issues with completing some clicks and other actions
Incident Report for Spektrix
Resolved
We are happy that there have been no more occurrences of this behaviour so we are marking this incident as resolved.
If you do notice any unusual behaviour with page loading or refreshing please contact us straightaway and we will continue to monitor on our side.
Posted Nov 24, 2022 - 16:23 GMT
Monitoring
Our internal logging is showing no further issues relating to this. We are also receiving reports from affected users that system performance is improving. We are continuing to monitor the situation and do further analysis and will provide further updates. Currently we expect there to be minimal issues relating to slow or refreshing clicks and payments should also all be processing successfully.
Posted Nov 24, 2022 - 14:11 GMT
Update
We are continuing to investigate this issue. Right now we believe that clicks are slow or causing pages to refresh. We don't believe you are reaching error pages as part of this. You may find when attempting a phone or chip and pin payment that the response is slow and results in an error - right now we believe this issue to be linked and a second payment attempt is likely to be successful.

We will continue to look into this and provide further updates.
Posted Nov 24, 2022 - 13:54 GMT
Investigating
We are investigating reports where some actions are failing to complete, for example some clicks are not completing on the first attempt.
This may also be affecting payment attempts, but we believe a second attempt will currently be successful.

We will update when we have more news.
Posted Nov 24, 2022 - 13:30 GMT
This incident affected: Spektrix System (UK and Ireland).