All Systems Operational

About This Site

Stay up-to-date on Spektrix's system status here. You can also subscribe to notifications above.

If you're experiencing something that isn't on this page, get in touch:

support@spektrix.com
UK & Ireland: 020 7183 3586
US & Canada: (646) 569-9097 or 1-800-961-5971

Spektrix System ? Operational
90 days ago
100.0 % uptime
Today
UK and Ireland ? Operational
90 days ago
100.0 % uptime
Today
US and Canada ? Operational
90 days ago
100.0 % uptime
Today
Payments Processing ? Operational
90 days ago
99.99 % uptime
Today
Opayo (formerly SagePay) ? Operational
90 days ago
100.0 % uptime
Today
Worldpay (formerly Vantiv) ? Operational
90 days ago
100.0 % uptime
Today
Authorize.Net ? Operational
90 days ago
100.0 % uptime
Today
Moneris ? Operational
90 days ago
100.0 % uptime
Today
PayPal Operational
90 days ago
99.98 % uptime
Today
dotdigital ? Operational
90 days ago
100.0 % uptime
Today
Support Services Operational
90 days ago
100.0 % uptime
Today
Support Centre and support@spektrix.com ? Operational
90 days ago
100.0 % uptime
Today
Phone Service - UK/Ireland ? Operational
90 days ago
100.0 % uptime
Today
Phone Service - North America ? Operational
90 days ago
100.0 % uptime
Today
APIs ? Operational
90 days ago
100.0 % uptime
Today
APIs - UK and Ireland ? Operational
90 days ago
100.0 % uptime
Today
APIs - US and Canada ? Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Mar 29, 2024

No incidents reported today.

Mar 28, 2024
Resolved - We're confident that the issue has now been resolved and all jobs should be running normally.

Thank you for your patience whilst we worked to resolve this.

Mar 28, 12:03 GMT
Monitoring - We are now seeing reports and customer lists should now be completing normally.

Jobs including Dotdigital mailings that have been delayed should also now start to complete

Mar 28, 11:52 GMT
Identified - We've identified the cause of the issue and have implemented a fix for the issue. We'll update here with more details shortly
Mar 28, 11:48 GMT
Update - We're implementing a process that should help with the issue, and will update on any impact of that here shortly

We continue to advise not resending or reattempting any jobs at this time

Mar 28, 11:35 GMT
Update - We are still seeing slowness for system jobs, and are continuing to investigate.

Reports and customer lists are running and completing, but slower than usual.

Jobs such as Dotdigital Mailings, bulk creation of Opportunities and Activities and bulk tagging are not currently completing.

We advise that you don't attempt to resend Dotdigital mailings or re-attempt jobs that aren't completing

Mar 28, 11:21 GMT
Update - We are continuing to investigate the issue and will update here again shortly
Mar 28, 11:04 GMT
Investigating - We're investigating some slower than expected report and customer list running times currently. Right now we're seeing these have some delays but these are currently completing. If you are waiting for a job or a mailing to finish it should complete so there is no need to run anything again.

We're looking into the cause of these delays and will update further with more information shortly.

Mar 28, 10:49 GMT
Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024
Resolved - After a period of continued close monitoring we're confident that there are no issues with the performance of the Spektrix system.
The broader network/internet provider related issues that some have experienced today appear to have resolved now based on the reports we've been receiving from you.

Mar 22, 15:02 GMT
Monitoring - The majority of users who had reported issues are now seeing a return to normal speeds.
Our investigation hasn't found any problems with the Spektrix system itself, and we continue to believe based on the nature of the reports we received, that any issues were related to problems with the BT/Openreach network, and only affected those who use a BT/Openreach affiliated ISP.

We are continuing to closely monitor on our side and if there are any further problems we will update here.

Mar 22, 13:00 GMT
Investigating - We have received several reports of slowness accessing the Spektrix system and also clients' websites.
We currently don't believe there are any issues directly with our system or infrastructure, but we are investigating further.

We have seen that BT has been having issues in certain locations that matches the locations of clients who have reported slowness - right now we believe this will be the cause of any problems you are experiencing.

If you know you do not use BT as an internet service provider, and are experiencing problems, please do get in touch with as much information as possible to aid our own investigation.

Mar 22, 11:47 GMT
Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.