Problems contacting Support
Incident Report for Spektrix
Resolved
Our phone lines are still happily operating as normal, and we don't foresee any further issues. Apologies again if you were trying to reach us during the earlier downtime!
Posted Apr 19, 2018 - 19:01 BST
Monitoring
Aaaaaaand we're back - we'll keep an eye on things, but it looks like regular service has been resumed, with calls reaching us as normal!
Posted Apr 19, 2018 - 17:14 BST
Investigating
We're experiencing some sporadic internet connection issues which may mean that the UK/Ireland Support line is unavailable. If you're unable to get through, please contact support@spektrix.com with your query and we'll get back to you as soon as possible!
Posted Apr 19, 2018 - 17:06 BST
This incident affected: Support Services (Phone Service - UK/Ireland).