We've been able to fix the underlying issue when clicking on Pre or Post Show emails buttons within Insights & Mailings. You can now safely access those areas of the system again.
Thanks for your patience on this.
Posted Jul 09, 2025 - 13:47 BST
Identified
We have identified an issue where clicking on the Pre or Post Show emails buttons with Insights & Mailings is causing slowness and error screens and is interfering with the Dotdigital integration.
The rest of the system and Dotdigital integration is operating normally.
We are rolling out a fix for this. This will take up to an hour. While this happens you should not touch the Pre or Post show emails areas of Spektrix until we let you know.
We appreciate your understanding on this and will be in touch soon with further updates.
Posted Jul 09, 2025 - 10:56 BST
This incident affected: Spektrix System (UK and Ireland) and dotdigital.