After monitoring for a sustained period, we're confident that the issues affecting Cloudflare have now been resolved by their team and all Spektrix-powered websites and services that use Cloudflare are fully operating.
To recap, Cloudflare is a third party service that forms part of our infrastructure to keep connections secure across the internet. Some services provided by Cloudflare had issues throughout the day - it's possible you may have had issues with your primary websites at various points today. There were specific issues affecting Spektrix "secure" iframes (primarily the checkout and login iframes) between around 13:30 GMT / 08:30 EST / 05:30 PST and 15:00 GMT / 10:00 EST / 07:00 PST. Within this timeframe customers are likely to have had issues purchasing tickets online.
Cloudflare have confirmed all issues have been resolved on their side and as always we will continue to proactively monitor the situation.
Posted Nov 18, 2025 - 16:27 GMT
Monitoring
Cloudflare have now implemented a fix to resolve the issue, so your website functionality should have returned to normal. We are continuing to monitor the situation to confirm that web journeys are working as expected. Thank you for your patience throughout this.
Posted Nov 18, 2025 - 15:07 GMT
Update
The ongoing Cloudflare outage is still affecting customers' ability to use your website. Cloudflare is part of our infrastructure that helps maintain secure connections across the internet, and so the issues are affecting key parts of the booking journey online. We're still monitoring the situation and will update here regularly and if we have any new information.
We've also noticed that this issue is affecting the request forms on the Spektrix Support website. If you have a time-sensitive seating plan, import, training or report request please send this in via email to support@spektrix.com
Posted Nov 18, 2025 - 14:26 GMT
Update
We're still actively monitoring this situation. If you're able to, we would recommend adding messaging to your website directing customers to contact you by phone to purchase tickets. We are confident that your Spektrix sales interface is unaffected, and you will still be able to process tickets on the phone and in person.
Posted Nov 18, 2025 - 13:53 GMT
Identified
Due to ongoing issues with the Cloudflare Global Network you may be seeing issues with your websites. This will be impacting your customers' ability to log in and check out on your website. We're actively monitoring the situation and will update here as soon as we have any further information.
Posted Nov 18, 2025 - 13:47 GMT
This incident affected: Support Services (Support Centre and support@spektrix.com) and Spektrix System (UK and Ireland, US and Canada).