Spektrix system, website integrations, API outage

Incident Report for Spektrix

Resolved

We're confident now that all work has been completed to fully restore all access and all systems are operational.

If you have any further questions or concerns regarding the issues today please reach out to us and we'd be happy to help and provide further information.

Thanks again for your patience this morning.
Posted Jun 10, 2025 - 10:39 BST

Monitoring

You should now be seeing that all elements of the Spektrix system are back up and running.

We're still working through elements of the fix and will be in a close monitoring period as we do this.
We'll keep you updated if anything changes as this happens.
Posted Jun 10, 2025 - 09:54 BST

Update

We're continuing to work through our fix for the system outage currently happening. To confirm this is impacting the Spektrix system and all elements of website integrations that will impact end-customers.

Both yourselves and end-customers will likely see 'Timeout' errors that will come from Cloudflare.

This issue relates to an infrastructure change and is not a data security issue.

We will continue to provide updates on an expected timescale as we have more information. We will update again in 10 minutes or sooner.
Posted Jun 10, 2025 - 09:47 BST

Identified

We're aware that the entire Spektrix system is currently down and inaccessible and you will see error pages when trying to use the system.

We know what the cause of this is and are working to resolve this now. It is likely that whilst we work through the fix the system will be down for a period of time. We will be able to estimate this better in approximately 10-15 minutes and will update further then.

Thanks for your patience as we work through this.
Posted Jun 10, 2025 - 09:33 BST
This incident affected: Spektrix System (UK and Ireland).