Support Centre Currently Down
Incident Report for Spektrix
Resolved
This incident has been resolved.
Posted May 08, 2021 - 14:30 BST
Investigating
Our Support Centre is currently inaccessible, during this period you will not be able to submit new tickets or access Support Centre content. We are still able to receive calls and access client systems so please do get in touch via phone if you have any urgent queries we can assist with.
Posted May 08, 2021 - 13:57 BST
This incident affected: Support Services (Support Centre and support@spektrix.com).