Issues with Support Phone Lines this morning
Incident Report for Spektrix
Resolved
You can now get through to the Spektrix Support team without any issues, however BT are still having a few problems with their internet and phone lines which might affect your organisation's internet access (https://www.bt.com/consumerFaultTracking/public/faults/tracking.do?pageId=31).

Sorry to the early birds who tried to call us at 9am this morning - please call us back if you weren't able to get through.
Posted Jul 20, 2016 - 09:48 BST
Update
Our issues this morning seem to be caused by issues BT are having with phone lines an broadband (https://www.bt.com/consumerFaultTracking/public/faults/tracking.do?pageId=31). These issues are only affecting our Manchester office, but you might find issues with your organisation's internet which will have an impact on your access to Spektrix. If you have 3G dongles it's worth getting them out!
Posted Jul 20, 2016 - 09:25 BST
Identified
We've now forwarded support calls to mobiles so you should be able to get through.
Posted Jul 20, 2016 - 09:12 BST
Investigating
We're having a few problems with our support phone lines this morning - you might have difficulty getting through to us before 10am. If you can't get through please leave a voicemail or e-mail us at support@spektrix.com and we'll get back to you.

We'll post an update here once we're back to normal.
Posted Jul 20, 2016 - 09:05 BST
This incident affected: Support Services (Phone Service - UK/Ireland).