Problems with Support Line
Incident Report for Spektrix
Resolved
The gremlins have been expelled from the phones and you can now get through to the lovely Support Team as normal.
Posted Feb 07, 2017 - 19:38 GMT
Identified
We're having a few gremlins with our UK Support phones this afternoon. We're picking up Support calls still, but it might take a little longer to connect to someone here.

If you need us, please hold the line or drop us an email on support@spektrix.com
Posted Feb 07, 2017 - 15:32 GMT
This incident affected: Support Services (Phone Service - UK/Ireland).