Our Support Centre is currently down
Incident Report for Spektrix
Resolved
Our Support Centre is now back up and running as normal. Please do call us on 020 7183 3586 (in the UK) or 646 569 9097 (in the US) if you need to flag any urgent requests which were sent through over the last couple of hours.
Posted Aug 26, 2016 - 18:37 BST
Update
Our Support Centre is still down so do give us a call on 020 7183 3586 (in the UK) or 646 569 9097 (in the US) if you need any assistance this evening. We'll update this page again when we have another update on this.
Posted Aug 26, 2016 - 18:17 BST
Identified
Our Support Centre is currently down so we can't access messages to support@spektrix.com or updates to any support tickets. If you need to contact us here in the Support team, please give us a call on 020 7183 3586. We'll keep you updated as we find out more.
Posted Aug 26, 2016 - 17:54 BST
This incident affected: Support Services (Support Centre and support@spektrix.com).