system.spektrix.com unavailable
Incident Report for Spektrix
Resolved
From a period of just over two hours, from 01:00-03:05 BST / 20:00-22:05 ET / 17:00-19:05 PT, your client interface and API access via system.spektrix.com was down. Access via custom domains was unimpacted, so web sales continued to be available and orders could confirm online during this time.

Overnight tasks such as scheduled reports, integrated mailings or partner API integrations will have failed during this time, and may need to be reattempted this morning.

Please reach out to support@spektrix.com if we can assist further we this.
Posted Apr 16, 2024 - 09:34 BST
Update
As of about 3AM BST/10PM EST we have resolved the issue and all Spektrix Systems are back up and fully operational. We will continue to monitor during this period to ensure proper service.

Summary:
Between 1-3AM BST/8-10PM EST all Spektrix Systems went down and returned the message "421 Misdirected Request." During this time Spektrix was inaccessible for use. However, websites using custom domains were able to continue sales as normal during this period.
Posted Apr 16, 2024 - 03:20 BST
Monitoring
As of about 3AM BST/10PM EST we have resolved the issue and all Spektrix Systems are back up and fully operational. We will continue to monitor during this period to ensure proper service.

Summary:
Between 1-3AM BST/8-10PM EST all Spektrix Systems went down and returned the message "421 Misdirected Request." During this time Spektrix was inaccessible for use. However, websites using custom domains were able to continue sales as normal during this period.
Posted Apr 16, 2024 - 03:17 BST
Update
Around 2AM BST/9PM EST our engineers discovered a problem with our SSL certificates. We are continuing to investigate.
Posted Apr 16, 2024 - 02:15 BST
Investigating
Around 1AM BST/8PM EST we began to see outages across all Spektrix systems. We are currently investigating this issue.
Posted Apr 16, 2024 - 01:35 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).